Ana Sayfa » *nix » qmail Kurulum Scripti

qmail Kurulum Scripti


BerbatKötüİdare EderGüzelHarika (Toplam 6 oy. 5 puan üzerinden ortalama 4,67 || Oy vererek siz de katkıda bulunabilirsiniz.)
Loading...

Geçenlerde 'i temel bileşenleri ile hızlıca kurabilmek için herhangi bir shell script var mıdır diye bakındım; bir kaç kırık linkten başka bir şey bulamadım. Bunun üzerine de http://www.lifewithqmail.org adresinde anlatılan kurulum prosedürünü uygulayan bir shell script yazdım. Aşağıdaki linkten edebileceğiniz bu script ile sıfırdan bir qmail kurulumu yapabilirsiniz.

Scriptin 5.x / 6.x ve 7.x / 8x için olan ayrı iki versiyonu var;

6.x http://www.syslogs.org/qmail/scripts/qinstaller.cnt6x.tar.gz
5.x http://www.syslogs.org/qmail/scripts/qinstaller.cnt55.v2.1.0.tar.gz

8.x http://www.syslogs.org/qmail/scripts/qinstaller.freebsd.v03.tar.gz

Kullanım:

Kuruluma başlamadan önce sisteminizde bash'ın yüklü olduğuna emin olun. ( ile default gelmektedir.)
sistemlerde  aşağıdaki comut ile kolayca kurabilirsiniz.

“pkg_add -r bash”

Sıkıştırılmış dosya içerisinde install-qmail.sh ve uninstall.sh isimli iki adet shell script dosyası ve bir README dosyası mevcut.  Kuruluma başlamadan önce README dosyasını okuyun.

Daha sonra sh install-qmail.sh diyerek kurulumu başlatın, yönergeleri takip edin ve yaklaşık 3 dakika içinde qmail'iniz hazır.

uninstall.sh scripti, install-qmail.sh scripti ile kurulmuş olan bir qmail'i sistemden kaldırmaktadır. Aksi durumlar için bu scripti kullanmayınız.

Not: Ilgili script qmail'i sadece temel bileşenleri (qmail-send ve qmail-smtpd) ile kuruyor.  Bu scripti , smarthost vs. gibi temel bileşenlerle çalışacak bir qmail ihtiyacına karşı pratiklik olsun diye hazırladım. Eğer tam teşekküllü bir qmail kurulumu yapmak istiyorsanız qmailtoaster kullanmanizi öneririm.

Scriptleri hali hazırda kullanımda olan bir OS üzerinde çalıştırmanız sorunlarla neden olabilir;  böyle durumlarda sorumluluk tamamen size aittir.

Visited 381 times, 1 visit(s) today
Kategoriler: *nix,Qmail |

Bu yazılar da ilginizi çekebilir:


- qmail Kurulum Scripti v0.2 – CentOS 5.4
- qmail Kurulum Scripti – CentOS 6.x
- qmail Kurulum Scripti – FreeBSD 9.x
- Netqmail
- Qmail Log Dosyalarının Ebatını Arttırmak

Yorumlar


  1. Bora KAYZEN | (Ekim 6th, 2009 2:31 pm)

    ilgili kurulum script’ini ubuntu 9.04 desktop edition üzerinde çalıştırdıgımda
    aşağıdaki uyarıyı alıyorum.. (erişmesinde ve indirmesinde her hangi bir problem yok..)

    sorun ne olabilir..?

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    daemontools-0.76.tar.gz paketinin size’i dogrulanamadi. Bu durumda devam
    edemiyoruz. Paketin download edilmesi sirasinda bir sorun olmus olabilir.
    Lutfen http://blog.cagriersen.net/qmail/src/daemontools-0.76.tar.gz
    adresine erisiminiz oldugunu kontrol ettikten sonra install.sh scriptini
    yeniden calistiriniz.

    [Cevapla]

    Cagri Ersen tarafından yanıtlandı.

    Merhabalar,

    Scriptin FreeBSD ve CentOS olmak uzere iki versiyonu var ve Ubuntu ile uyumlu degiller malesef.

    Vaktim oldugu zaman bir ara duzenleyip Ubuntu uyumlu hale getirebilirim ama su siralar zor gorunuyor.

    [Cevapla]

  2. Mustafa | (Nisan 12th, 2011 4:23 pm)

    qmail-smtpd/run dosyasinin ebati dogru mu ?

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!”’!!!!!!!!!!!!!!!!!!!
    Ooopss…

    qmail-smtpd/run dosyasinin size’i dogrulanamadi! Download sirasinda
    bir sorun olusmus olabilir. Bu durumda kuruluma devam edemiyoruz.

    Lutfen asagidaki adimlari izledikten sonra install-qmail.sh
    scriptini yeniden calistirin.

    1 – http://blog.cagriersen.net/qmail/qmail-smtpd/run adresine erisiminiz
    oldugundan emin olun.

    2- /qmail-install-scripts dizinindeki uninstall.sh scriptini
    calistirarak su ana kadar yapilan islemleri geri alin.

    3 – Son olarak, install-qmail.sh scriptini yeniden calistirarak
    qmail kurulumunu yeniden baslatin.
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!”’!!!!!!!!!!!!!!!!!!!

    freebsd^ye kurulum esnasında böyle bir hata aluyorum 3 defa yeniden denedim daha önce kurmuştum sizce neden olabilir.

    [Cevapla]

    Cagri Ersen tarafından yanıtlandı.

    Selamlar,

    Sorunun nedeni, scriptte kucuk bir degisiklik yapmamdan kaynaklaniyordu. Su an duzeltildi, simdi sorunsuz olarak kurulumu yapabilmeniz gerekir.

    [Cevapla]

    Mustafa tarafından yanıtlandı.

    teşekkürler, oldu kurulum.

    [Cevapla]

  3. Val | (Şubat 16th, 2015 4:14 pm)

    Merhaba,

    Çağrı Hocam 8x için demişsiniz ben freebsd 10 sürümünde denedim. utmpx için hata verdi. qmail-extra-patch-utmpx.patch patchini uyguladım. Belki aynı hatayı alan olursa yardımcı olur.

    sevgiler.

    [Cevapla]

  4. Val | (Şubat 16th, 2015 4:49 pm)

    Çağrı hocam diğer yazınızı görmemiştim. Yazdığım mesajı izansızlık olarak algılamayın lütfen.

    Kolay gelsin.

    [Cevapla]

    Cagri Ersen tarafından yanıtlandı.

    Yoo izansızlık olarak algılamadım :)

    Rica ederim.

    [Cevapla]

Trackbacks

Yorumda bulunun.